FlowSavvy - Degraded performance / Calendar syncing disabled – Incident details

Degraded performance / Calendar syncing disabled

Resolved
Operational
Started about 1 year agoLasted 1 day

Affected

General

Operational from 10:50 PM to 4:20 AM

Google Calendar sync

Operational from 10:50 PM to 4:20 AM

iCloud sync

Operational from 10:50 PM to 4:20 AM

Outlook sync

Operational from 10:50 PM to 4:20 AM

Updates
  • Resolved
    Resolved

    This issue has been resolved

  • Monitoring
    Monitoring

    Syncing has been re-enabled. We will continue monitoring performance over the next few hours before marking this incident as resolved.

    Note: If your sync failed earlier before we disabled all syncing, you may need to re-activate syncing by going to Settings > Calendars and selecting "Try again".

  • Update
    Update

    We are working on scaling our systems to accommodate increased sync load. This will include a brief window (less than 5 minutes) during which FlowSavvy will be unavailable while we scale our systems. This brief downtime will occur between 8-8:30pm EST (1-1:30am UTC).

  • Update
    Update

    We have identified the root cause of the slow performance and are working on a fix.

    Calendar syncing will remain disabled until the fix is complete. We will provide an update by 7pm EST (12am UTC)

  • Identified
    Identified

    Enabling syncing caused the performance issues to return, so we have disabled syncing again. We apologize for the inconvenience and will provide a status update by 4pm EST (9pm UTC)

  • Monitoring
    Monitoring

    Syncing has been re-enabled and all services are operational. Please go to Settings > Calendars and select "Try again" to re-activate syncing.

    We will continue monitoring performance over the next few hours before marking this incident as resolved.

  • Identified
    Identified

    We have identified the root cause of the performance issues and are working on a fix. Performance has returned to normal for all services except calendar syncing, which will remain disabled until the fix is complete.

    We will provide periodic status updates. In the meantime, we recommend reviewing your external calendars (Google, iCloud, Outlook) to ensure you don't miss meetings. Thank you for your patience!

  • Update
    Update

    Calendar syncing appears to be a large contributor to the slow performance. We have temporarily disabled Google, iCloud, and Outlook syncing while we investigate the issue.

  • Investigating
    Investigating

    We are investigating an issue causing slow performance and syncing.