FlowSavvy - Outlook Outage – Incident details

Outlook Outage

Resolved
Major outage
Started about 1 year agoLasted about 2 hours

Affected

Outlook sync

Operational from 11:10 PM to 1:10 AM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved. If your Outlook sync failed during this incident, please go to Settings, then Calendars, and try restarting the sync.
  • Investigating
    UTC
    Investigating

    Outlook authentication and syncing are not working